UltraSeAT: tras la cadena de montaje

30 noviembre, 2006

Solución a los problemas de sonido con YouTube y GoogleVideo

Filed under: Linux,Navegación,Sistemas Operativos,Tutoriales (howto) — ultraseat @ 04:24 am

[añadido de ultima hora 04/12/2006: tras las últimas actualizaciones automáticas de mi Linux Ubuntu Dapper, el problema parece haberse solucionado]

Muchos usuarios de Ubuntu Dapper estamos teniendo problemas con el sonido en los videos de YouTube o GoogleVideo al acceder mediante firefox. Supongo que el problema se extenderá también a otros navegadores.

La forma en que lo he solucionado es la siguiente:

Abrimos una consola e introducimos los siguientes comandos:

sudo su

(introducimos la contraseña de superususario)

apt-get update

apt-get install libflash-mozplugin

sudo killall aoss

sudo killall esd

Reiniciamos Firefox.


[*]Es muy probable que tras cada reinicio del sistema, haya que teclear, antes de cargar Firefox por primeravez los comandos

sudo killall aoss

sudo killall esd

En algunos casos puede que no se encuentre instalado el demonio ALSA, así que habrá que instalarlo:

sudo aptitude install alsa-oss

También es conveniente especificar a mano que Firefox utilice el demonio de sonido ESD o ALSA.

sudo gedit /etc/firefox/firefoxrc

*Si queremos que utilice ALSA tenemos que editar el archivo para que tenga un aspecto similar al que se muestra a continuación:

# which /dev/dsp wrapper to use

FIREFOX_DSP=”aoss”

# Note that “auto” and “esd” involve the use of esddsp, which

# is known to be buggy and to make Firefox unstable.

# See https://launchpad.net/malone/bugs/29760.

*Si por el contrario queremos que utilice ESD:

# which /dev/dsp wrapper to use

FIREFOX_DSP=”esd”

# Note that “auto” and “esd” involve the use of esddsp, which

# is known to be buggy and to make Firefox unstable.

# See https://launchpad.net/malone/bugs/29760.

Finalmente, si usamos ESD tan sólo nos queda crear un enlace simbólico en el arranque, para que el plugin flash busque en el sitio correcto el socket del demonio de sonido.
Con el fin de conocer nuestro UID tecleamos en la consola lo siguiente:
id

Allí aparece algo similar a esto:

uid=1000(raistlin) gid=1000(raistlin) (…)

Como vemos nuestro uid es 1000.

Ahora vamos al menu Sistema – preferencias – sesiones – programas de inicio y pulsamos sobre “añadir”. Allí tenemos que escribir lo siguiente:

ln -s /tmp/.esd-UID /tmp/.esd

sustituyendo UID por el valor que hemos visto anteriormente. En mi caso como el UID es 1000 tendré que escribir ésto:

ln -s /tmp/.esd-1000 /tmp/.esd

Le damos a aceptar, y vamos a Sistema – Salir – Cerrar sesión. Volvemos a entrar y a partir de entonces escucharemos el sonido en los videos de youtube y flash en general.

Anuncios

7 comentarios »

  1. Estimado, la verdad tengo N problemas con el youtube en mi PC, pero no cacho el lenguaje que usaste, ni dónde meter los comandos, cómo abro la consola, sorry, pero soy un simple usuario no más…

    Comentario por Rodrigo — 6 diciembre, 2007 @ 03:02 am

  2. puta madre no entiendo ni mierda por favor escribe en español concha de tu madre

    Comentario por miguel — 22 diciembre, 2007 @ 19:15 pm

  3. Esto es para Linux. En las últimas versiones de Linux Ubuntu, estos problemas no existen, así que esta entrada ya no hace falta.

    Comentario por ultraseat — 2 enero, 2008 @ 00:27 am

  4. compañero k coño dices joder k o te entiendo una puta mierda joder

    Comentario por cangath — 25 agosto, 2008 @ 23:27 pm

  5. no entiendo a que consola te refieres puedes aclarar eso? donde encuentro esa consola en que programa esta o debo instalar… aclarame eso porfa no tengo idea de que consola es esa… tengo sonido solo en el reproductor de windows pero ninguno de los videos de you tube u otros navegadores se oye el sonido

    Comentario por micka — 22 octubre, 2008 @ 20:34 pm

  6. Micka, este artículo trata de problemas de sonido al visualizar contenidos de Youtube en Linux. Para Windows este procedimiento no sirve, ya que es un sistema operativo diferente.
    Si trabajas con Windows, probablemente deberías reinstalar flash.

    Comentario por ultraseat — 26 octubre, 2008 @ 03:06 am

  7. Thank you for sharing your info. I really appreciate your efforts and I am waiting for your further write ups thanks once
    again.

    Comentario por views — 1 julio, 2013 @ 10:20 am


RSS feed for comments on this post. TrackBack URI

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Blog de WordPress.com.

A %d blogueros les gusta esto: